Thread.critical does not exist in ruby 1.9 anymore
[booh] / lib /
drwxr-xr-x   ..
drwxr-xr-x - booh