work with recent ruby-gnome2