move check for gimp and firefox to when needed, to allow soft require