Thread.critical does not exist in ruby 1.9 anymore