document rg2 version problems
authorGuillaume Cottenceau <gcottenc@gmail.com>
Mon, 20 Oct 2008 10:56:47 +0000 (12:56 +0200)
committerGuillaume Cottenceau <gcottenc@gmail.com>
Mon, 20 Oct 2008 10:56:47 +0000 (12:56 +0200)
INSTALL

diff --git a/INSTALL b/INSTALL
index 2bf6ba6..df9e160 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -4,7 +4,11 @@ This software requires for compiling:
 - devel of gtk
 - ruby
 - ruby-gettext >= 0.8.0
-- ruby-gtk2 >= 0.12
+- ruby-gtk2 >= 0.12; notice:
+  - ruby-gtk2 0.15.0 and 0.17.0 should be avoided, they are known
+    problematic versions (crash with 0.15.0, memory leak with 0.17.0)
+  - with ruby >= 1.8.7, ruby-gtk2 >= 0.18.0 should be used, otherwise
+    crashes will occur
 - devel of ruby-gnome2 (mkmf-gnome2.rb, rbgobject.h)
 - devel of libexiv2 (and thus, g++)